Once installed in Eclipse, the Code Sight interface appears in a tabular view.
-
In the code editor, icons next to line numbers show issues and other findings. A line of code that has an issue is highlighted.
-
The Code Sight view has various tabs that appear at the bottom of the Eclipse window.
-
The Local View tab includes controls for running scans.
-
The Team View displays remote issues detected by Polaris, Coverity Connect, or Coverity on Polaris.
-
Tip:
If you don’t see a Code Sight tab in the Eclipse window, go to the menu and choose
Window → Show View → Other.
This opens the Show View dialog. In the hierarchy that the dialog displays, click to expand the
Black Duck Code Sight entry.
Click and Ctrl+click to choose the Code Sight views you want to see, then click Open.