The General settings panel includes the check box for enabling Telemetry in Code Sight data collection. For the Eclipse and JetBrains (including IntelliJ) IDEs, it also links to preferences for the particular IDE, which include interface colors and keyboard shortcuts.
Visual Studio displays a telemetry panel that shows only the Telemetry check box. (The highlighting and keyboard shortcut options appear on the Preferences drop-down menu, not in this dialog.)
In VS Code, the check box for telemetry appears on
the STATUS → Code Sight Settings panel.
IDE preferences and customizing colors or keyboard shortcuts
Code Sight Preferences give you access to the color-customization and keyboard-shortcut options that are native to the IDE in which Code Sight is running.
For some users, customizing colors in the interface is a convenience. For users who have difficulty distinguishing between certain colors, being able to customize colors in the interface—especially in the code editor—can be an important feature.
Using the color controls, you should be able to create a custom display that is more easily legible.
The way to access these options varies depending on the IDE, as described in the following sections.
Eclipse
In Eclipse, links to the native customization controls appear on the Authentication preferences panel.
You can also open the Eclipse Preferences dialog and then navigate to General → Appearance → Colors and Fonts to customize colors in the UI, or to General → Keys to create or customize keyboard shortcuts.
Opening the Eclipse Preferences dialog depends on the operating system you use.
- In macOS: On the menu bar, choose Eclipse → Settings or Preferences. (The name of the menu choice can depend on which version of macOS is running.)
- In Windows or Ubuntu: On the menu bar, choose Window → Preferences.
The JetBrains family, including IntelliJ
In the Black Duck Code Sight Preferences panel → General group, click Issue Highlighting Colors or Keyboard Shortcuts.
These links take you to the IntelliJ customization controls.
Microsoft Visual Studio
In the Visual Studio Options dialog, the Black Duck options do not include UI customizations, but you can click the down-arrow to the right of the Preferences icon and link, then choose Issue Highlighting or Keyboard Shortcuts from the drop-down menu.
Microsoft Visual Studio Code
To change colors:
- On the Code menu (macOS) or the File menu (Windows or Linux), choose Settings.
- On the Settings tab, search for “Code Sight”, then use the settings in these entries to adjust display colors.
- On the Code menu (macOS) or the File menu (Windows or Linux), choose Settings → Keyboard Shortcuts.
- On the Keyboard Shortcuts tab, edit the entries for the shortcuts you want to customize.